Showing results for 
Search instead for 
Do you mean 
Community Home Request Access Read Blogs Share Your Ideas Search Community View My Settings
Reply
New Member
Posts: 17
Registered: ‎09-10-2009

SLX 7.5.0 LEADSOURCEID issue

Hello,

 

while working with sdata and xml, I've tried to search and update existing leads in SLX.

When I try to search a leads using this address for example, http://SERVERSmiley TongueORT/sdata/slx/dynamic/leads?where=Company like'COMPANYNAME' ,

I was only possible to search for leads, if the lead has an ID in the LEADSOURCEID field or if it has NULL in it.

I created a lead manually in SLX and checked if this field contains a value using SQL management console. 

Then I've noticed that this field is empty.

 

Now my question is:

Is this a SLX bug in this version?

Is the user able to configure SLX that way that this field is filled when creating a lead over SLX?

 

Regards

 

Kai

Employee
Posts: 191
Registered: ‎03-13-2009

Re: SLX 7.5.0 LEADSOURCEID issue

the lead source information in the lead table comes from the lead sources(manage lead sources) table, you will need to pass the relevant id=import from the lead source table and update it in the lead table. If you dont specify any lead source it stores it as null.
New Member
Posts: 17
Registered: ‎09-10-2009

Re: SLX 7.5.0 LEADSOURCEID issue

the crazy part is, if I use the settings, as they come through the installation, the field is empty.and not NULL
Employee
Posts: 191
Registered: ‎03-13-2009

Re: SLX 7.5.0 LEADSOURCEID issue

fill the foriegn key value of the lead source table to the lead table and u should be able to go ahead.
New Member
Posts: 17
Registered: ‎09-10-2009

Re: SLX 7.5.0 LEADSOURCEID issue

yes that was what I've done.

I only wanted to know if it's a slx issue that the leadssourceid field isn't filled when creating a lead manually