Showing results for 
Search instead for 
Do you mean 
Community Home Request Access Read Blogs Share Your Ideas Search Community View My Settings
Reply
Highlighted
Nickel Elite Contributor
Posts: 86
Registered: ‎10-21-2009

Problem with Using Code in Picklist StorageMode

Hi All,

 

We are in process of Migrating SalesLogix LAN customizations to SalesLogix Web 8.0.

 

Here in Account Product form I need to Add a Picklist.  As per earlier LAN implementation I need to Store Piclist Short Text in the DataBase. Though by Setting Storage Mode as Code I managed to Store ShortText (Code) in the back end, but while opening the form in Edit Mode, Picklist shows empty.

 

I have also tried to set, Picklist Value dynamically in Page_OnLoad, but nothing happens.

 

Please Suggest.

 

Code Snippet added on the Page load is as Follows,

 

if (this.EntityContext.EntityID.ToString().ToUpper() != "INSERT")
        {
        //Sale Indicator
            System.Collections.Generic.IList<Sage.SalesLogix.PickLists.PickList> sales = Sage.SalesLogix.PickLists.PickList.GetPickListItemsByName("Sale Indicator", true);
            if (!String.IsNullOrEmpty(Convert.ToString(objUserDefaults.SALEINDICATOR)))
            {
                foreach (Sage.SalesLogix.PickLists.PickList sale in sales)
                {
                    if (sale.Shorttext.ToString().ToUpper() == objUserDefaults.SALEINDICATOR.ToString()) //Do something               
                    {
                        pklst_SaleIndicator.PickListValue = objUserDefaults.SALEINDICATOR.ToString();
                       //     sale.Text.ToString();
                    }
                }
            }

}

 

Thanks in Advance

Malay Mukherjee

 

 

 

Highlighted
Copper Contributor
Posts: 10
Registered: ‎05-14-2009

Re: Problem with Using Code in Picklist StorageMode

We are seeing the same thing.  When StorageMode=Code, the picklist works - can select and code will be saved to the DB.  But when opened in Edit Mode, field is blank.

---
Chris Reich
www.customerconnected.com
Highlighted
Copper Contributor
Posts: 248
Registered: ‎04-20-2009

Re: Problem with Using Code in Picklist StorageMode

[ Edited ]

Same here - Web v.8. Is this a known issue? Anybody got a favorite workaround? Thanks