Showing results for 
Search instead for 
Do you mean 
Community Home Request Access Read Blogs Share Your Ideas Search Community View My Settings
Reply
Highlighted
Nickel Elite Contributor
Posts: 107
Registered: ‎03-09-2011
Accepted Solution

Help with Deployment

I typically work in 4 environments

 

Local for most development tasks. This includes App Architect against a local database.

 

I just realized that scripted promotion deployments to Dev, Staging and Production are not deploying roles and secured actions.

 

My scripted deployment worked fine in 7.5.2 but now with Secured Actions and roles it is not deploying the roles and secured actions to the database.

 

What is the reccomended method for deploying/promoting through different environments?

 

All I can find in the documentation is Open App Architect, Build Project, then deploy. I don't like to use these manual steps when promoting changes to higher environments.

 

 

Nickel Elite Contributor
Posts: 107
Registered: ‎03-09-2011

Re: Help with Deployment

Ok, more info.

 

For some reason the roles, securedactions, and secured actions role tables are empty in my higher environments.

 

Created a bundle to insert those records from my local system.

Instaled the bundle, assigned the user to the role and now it works as expected.

 

So I'll do some refinements and will have to remember to track securedaction and role changes across environments if required.

 

Still looking for decent how to or best practice for deploying web components. To different environments.

Bronze Super Contributor
Posts: 236
Registered: ‎03-30-2009

Re: Help with Deployment

Unfortunately, secured actions and roles are data driven and not part of standard deployments.  The only way to migrate them from one env to another is thru data movement.  You use the Windows Architecht to bundle up database rows from any given table, or you can write SQL to copy the data.

Mike LaSpina
Professional Services Consultant

Sage
8800 N Gainey Center Dr Ste 200
Scottsdale AZ 85258
Tel: 480-383-5344
Cell: 480-321-6637
Fax: 480-556-4090
mike.laspina@sage.com

Your Business in Mind.
Nickel Elite Contributor
Posts: 107
Registered: ‎03-09-2011

Re: Help with Deployment

Thanks, I had a feeling that was what I needed to do.

Good news. I have my secured actions, roles, and users sorted out and all is working as it should now. In the future, dev, and staging environments are copied down for production, so this issue should go away.

I much prefer the new security model and hope it is implemented in the LAN Client in the future.