Showing results for 
Search instead for 
Do you mean 
Community Home Request Access Read Blogs Share Your Ideas Search Community View My Settings
Nickel Contributor
Posts: 51
Registered: ‎07-31-2008

Re: Error Message

I should be able to record something for you, but here is some more info...


-  Both servers have 4GB of RAM (and operate with memory to spare).

-  I'm not actualy "saving" the entity, or is it triggering a "build".  Upon altering the field size and closing the property dialog, AA appears to hang for a couple minutes while it tries to refresh/rebuild the entity.  This process somtimes completes, but usualy fails.

- I'm not certain if there was any output on the build window.  I didn't check it since i was not requesting a build, but I will be sure to capture it when I recreate the issue for you.


What is the best way to get a video to you?  The file may be too large to post here...

Posts: 63
Registered: ‎08-06-2009

Re: Error Message

You could send my a private email ( with a link to an ftp site or maybe a dropbox.

If something else is more convenient, let me know and we can work something out.

Nickel Contributor
Posts: 51
Registered: ‎07-31-2008

Re: Error Message



I’m finally getting around to posting the video...  [link omitted]


The link to download has been emailed to you...


I’ve tried it on other entities with snippet properties, and I get the same issue.  Nuke and Pave doesn’t resolve the issue.


Simplest steps to reproduce are to change the field size on the property dialog from the Property window of an entity with a code snippet property.  Once you save the entity after changing the text size, the step on the snippet property is dropped, and I haven’t found a way to recover (short of re-adding it).


Since I’ve stopped using Code Snippet Properties, I’ve stopped having issues.




Copper Contributor
Posts: 19
Registered: ‎12-19-2011

Re: Error Message

Sorry, i know this is a really old post, but i want to document the real solution for this problem when generating the hibernates on AA.


It is due to a bad relationship, sometimes with the entity "owner", or with a non existing table, or an entity within another entity package (the other entity not in "SalesLogix Application Entities").


Remove the relation and rebuild everything.  It should work.

Nickel Contributor
Posts: 57
Registered: ‎03-18-2010

Re: Error Message


I had the same issue.
In my case, I unchecked "seccodeid" and then I put it back. This operation caused the same bug.

Restore "seccodeid" in the model solved my problem.

Best regards,

Libert Damien