Showing results for 
Search instead for 
Do you mean 
Community Home Request Access Read Blogs Share Your Ideas Search Community View My Settings
Reply
Highlighted
Bronze Super Contributor
Posts: 152
Registered: ‎02-01-2011

Bug in GroupBuilder 7.5.4.7129? Multiple conditions

SLX 7.5.4 up to Web HF 5. I have a group with multiple conditions: one condition where a date field is greater than "2/2/2011" and a second condition where a boolean field == "T". In the web UI I get: "Displaying 1 - NaN of" indicating a group problem. In SLX Profiler, I get: "Multiple-step OLE DB operation generated errors. Check each OLE DB status value, if available. No work was done." In the Event Viewer I see the following snip:

 

...(A4.BOOL1='T') AND ((A4.DATE1>Smiley Very HappyateTime0) OR (A4.DATE1 IS NULL))...
GroupId: p6UJxxxxxx
Group Name: TESTGROUP
CurrentUser: ADMIN
Error Message: Command parameter[1] '' is invalid.
Command parameter[2] '' is invalid.

 

The group builder seems to get hung up on supplying parameters to the query. In Web HF5, the GroupBuilder DLLs to version .7129 from .7077. I've switched out the DLL back to .7077, hopefully it won't cause other issues. Has anyone else had problems with Web HF 5?

Andy Freeman
TrellisPoint, LLC
Highlighted
Copper Contributor
Posts: 6
Registered: ‎08-02-2009

Re: Bug in GroupBuilder 7.5.4.7129? Multiple conditions

Did you get a resolution to this issue?

Highlighted
Bronze Super Contributor
Posts: 152
Registered: ‎02-01-2011

Re: Bug in GroupBuilder 7.5.4.7129? Multiple conditions

No resolution, I just reverted to the GroupBuilder.dll from HF4 which appears to work.
Andy Freeman
TrellisPoint, LLC
Highlighted
Copper Contributor
Posts: 10
Registered: ‎04-07-2011

Re: Bug in GroupBuilder 7.5.4.7129? Multiple conditions

We ran into this, it only came up on Unicode enabled databases - 7.5.4 HF06 (not released yet) does contain a working fix for this though