Showing results for 
Search instead for 
Do you mean 
Community Home Request Access Read Blogs Share Your Ideas Search Community View My Settings
Reply
Highlighted
Copper Contributor
Posts: 94
Registered: ‎04-15-2009

Application Architect error on opening

Hi,

 

I am in mid of Upgrading a client database from slx 6.2.6 to 7.5.3 on Oracle 10 g R2 platform.

After upgrading and applying necessary service packs when I Open Application Architect I get the error as follows:


"Core Service Sage.SalesLogix.Security.FieldLevelSecurityService, Sage.SalesLogix.Security,  is not available and is required to run this application."

 

I am able to continue loading Application Architect however after deplyment of website I am not able to run the SLX web client properly  e.g. I am not able to view the Account details but am able to view the groups.

 

OS is Win 2008 R2 (64 bit).

 

Can some one tell me where am I going wrong? Did I forget to action some step?

 

Thanks in advance

Thanks and regards

Sandeep Gaykhe

Thanks and Regards
Sandeep Gaykhe
Providian Global Solutions
Highlighted
Copper Super Contributor
Posts: 172
Registered: ‎07-06-2010

Re: Application Architect error on opening

I just fixed a similar problem on a 7.5.2 installation. I am reasonably sure it is the version of the 10g driver you are using. Try using the 10.2.0.1 R2 driver. 

 

 

Highlighted
Bronze Super Contributor
Posts: 236
Registered: ‎03-30-2009

Re: Application Architect error on opening

There is also an issue with the Oracle provider and installing SalesLogix in a directory containing Parenthesis.  Make sure that you have not installed SLX in the default 64 bit directory of "C:\Program Files(x86)".  If so, you'll want to un-install and reinstall to a different folder.

Mike LaSpina
Professional Services Consultant

Sage
8800 N Gainey Center Dr Ste 200
Scottsdale AZ 85258
Tel: 480-383-5344
Cell: 480-321-6637
Fax: 480-556-4090
mike.laspina@sage.com

Your Business in Mind.
Highlighted
Copper Contributor
Posts: 94
Registered: ‎04-15-2009

Re: Application Architect error on opening

Thanks Mike and Elliot for your views.

Mike I was not aware of the fact you have mentioned in your mail regarding installation directory. I think the installation directory must be default only as I dont think I had made any changes over there. Does the program location defect holds true for even installation on SQL server database?

Also let me know does this happen for any 64 bit OS?As I see a major problem in case of all client installations on 64 bit OS due to the fact that Sales Client setup wizard does not allow to change the installation / program location.

Also in last two months client has upgraded to Oracle 11.2.0.1.

On SLX server the situation is like this

OS -64 bit

SLX - 32 bit (No option)

Oracle client installed - 32 bit version 11.2.0.1

I would check the point Mike has made and revert.

Anyways thanks a ton for the reply.

Thanks and Regards
Sandeep Gaykhe
Providian Global Solutions
Highlighted
Copper Super Contributor
Posts: 172
Registered: ‎07-06-2010

Re: Application Architect error on opening

I don't know how to change the install directory either, but right now I do have a working instance of 7.5.2 in that directory. We'll keep an eye on it. What kind of symptoms are demonstrated when the app is installed in a directory with parens?
Highlighted
Bronze Super Contributor
Posts: 236
Registered: ‎03-30-2009

Re: Application Architect error on opening

All I know for sure is that this was an issue between Oracle DBs and version 7.5.1.  It may have since been fixed.  Sypmtoms of the problem would be errors connecting to your Oracle DB thru connection manager.  If you're getting that far, then you do not have this issue.

Mike LaSpina
Professional Services Consultant

Sage
8800 N Gainey Center Dr Ste 200
Scottsdale AZ 85258
Tel: 480-383-5344
Cell: 480-321-6637
Fax: 480-556-4090
mike.laspina@sage.com

Your Business in Mind.