Showing results for 
Search instead for 
Do you mean 
Community Home Request Access Read Blogs Share Your Ideas Search Community View My Settings
Reply
Copper Contributor
Posts: 10
Registered: ‎08-12-2011
Accepted Solution

Activities page: "Displaying 1 - NaN of undefined"

We have SalesLogix 7.5.3, and we have a couple problems related to Activities. On the Activities page all the tabs say, “Displaying 1 – NaN of undefined” rather than displaying data. We also do not get any results for the Welcome screen widget “Today’s Activities”. Instead of displaying data, we only get the title bar for the widget displayed. Both these problems suddenly appeared in our development environment when we rebuilt the portal. Can you think of anything that would cause them to suddenly stop working?

 

The code for “Today’s Activities” exactly matches the out-of-the-box code we got from SalesLogix Support. I suspect these problems have to do with the connection. The Activities page displays data for "All Open" in the LAN client, but not in the web client.

Highlighted
Nickel Contributor
Posts: 59
Registered: ‎07-30-2010

Re: Activities page: "Displaying 1 - NaN of undefined"

It might be worth checking the data being returned in JSON format via FireFox and the plugin "FireBug", I have seen this in the past and the issue was that an account name was being stored in the database with a double quote ("), this causes the JSON to be invalid.

Richard Anderson
CRM Consultant
K3 CRM
Copper Contributor
Posts: 10
Registered: ‎08-12-2011

Re: Activities page: "Displaying 1 - NaN of undefined"

We may have found the cause of this problem. It looks like it was a bad DLL. We reverted the SageGroupBuilder.dll, and this appears to have fixed the problem.