Showing results for 
Search instead for 
Do you mean 
Community Home Request Access Read Blogs Share Your Ideas Search Community View My Settings
Reply
Highlighted
New Member
Posts: 2
Registered: ‎11-16-2009

ExecuteSQL in SLX 7.5.2

Hi Everyone,

 

One of our clients just upgraded to 7.5.2 and now some custom code from the 6.2 days isn't working.

 

They have a custom form that creates accounts.  The code is somewhat like this:

 

Line 1: strSQL = "insert into account (accountid, account ... etc.

Line 2: objSLXDB.ExecuteSQL strSQL

 

It is followed up by inserts for addresses, contacts, etc.

 

It all works fine in the network environment, but now the accounts created will not synchronize to remotes.  The interesting thing is that the contact we create at the same time does synchronize, but it isn't linked to an account...

 

Any idea of what might have changed with 7.5.2?

 

Thank you!

 

Joseph

 

Highlighted
Employee
Posts: 535
Registered: ‎03-30-2009

Re: ExecuteSQL in SLX 7.5.2

I'm not certain this is your issue, but have you double checked that a record is getting inserted into the AccountSummary table as well, and that all the necessary AccountSummary fields are populated including AccountSummary.SecCodeID ?

 

 

Todd Hardin
SalesLogix Professional Services Group
Highlighted
New Member
Posts: 2
Registered: ‎11-16-2009

Re: ExecuteSQL in SLX 7.5.2

Yes it is.  Everything looks perfect in both tables.  It also created the address, etc.

 

Interesting thing is that the contact created at the same time, and in the same method, IS synchronized, while the account is not.

 

Any other ideas?

Highlighted
Employee
Posts: 535
Registered: ‎03-30-2009

Re: ExecuteSQL in SLX 7.5.2

Suggest posting all of the code - maybe something will jump out at one of us.

 

 

Todd Hardin
SalesLogix Professional Services Group