Showing results for 
Search instead for 
Do you mean 
Community Home Request Access Read Blogs Share Your Ideas Search Community View My Settings
Reply
Highlighted
New Member
Posts: 9
Registered: ‎05-26-2011

Customer package release to "EVERYONE" not released to everyone

I recently updated to SP4, and as usual had to change some of the new forms around to account for out internal customizations.  Servers and Clients are running SLX v.7.5.4.7048

 

Made the changes in Architect for the LAN Clients, and then released the new forms to "EVERYONE"...however, they do not show up on my login.  I even tried to released them specifically to my account, log in on another users system and log in on my system with another users login...still the same issue (but only with my account as far as I can tell).

 

Anyone have any idea what might be causing this issue, not just so I can correct it but also prevent it from happening again.

 

-Jason

Highlighted
Silver Super Contributor
Posts: 801
Registered: ‎03-24-2009

Re: Customer package release to "EVERYONE" not released to everyone

Check there are no duplicates in plugin table of same name (should be 2 - 1 original and 1 released).
Highlighted
New Member
Posts: 9
Registered: ‎05-26-2011

Re: Customer package release to "EVERYONE" not released to everyone

ok, I did find that there was a duplicate, but it seems that the original is released because the other 2 entries have the PLUGINID of the released version in the BASEDON Column.

 

All 3 of the same DTS for Modified Date, but I deleted the one where the USERID was not a system ID.  However, the issue still remains.  There must be another table the identifies which forms are associated with individual users, correct?

Highlighted
Silver Super Contributor
Posts: 801
Registered: ‎03-24-2009

Re: Customer package release to "EVERYONE" not released to everyone

No, just the one table. Use Architect to create a project/bundle of the item. Then use SQL to delete them all and then re-add via Admin.
Highlighted
New Member
Posts: 9
Registered: ‎05-26-2011

Re: Customer package release to "EVERYONE" not released to everyone

Excellent, that worked!  Any ideas what may have caused it to happen?  I'd rather not go through that again if I don't have to.

Highlighted
Silver Super Contributor
Posts: 801
Registered: ‎03-24-2009

Re: Customer package release to "EVERYONE" not released to everyone

Unfortunately, no - but sounds like you had a bad plugin. The issue is - if you do a new plugin (form, group etc) and release that - does it now work or still have the same issue ?
Highlighted
New Member
Posts: 9
Registered: ‎05-26-2011

Re: Customer package release to "EVERYONE" not released to everyone

I will have to check.  The form that was pushed out was a customized version of Contact Details from 7.54.  It was designed and released as the Admin User.

 

The previous form was a customized version of the Contact Details from 7.53.  The only real difference (besides the back-end changes Sage made) was the label for one of the custom fields, otherwise I would not have realized it.

 

I have some other cusomizations that have been on the drawing board for some time now, so I'll get one of those complete this weekend and push it out to see if it is released correctly to everyone.