Showing results for 
Search instead for 
Do you mean 
Community Home Request Access Read Blogs Share Your Ideas Search Community View My Settings
Reply
Highlighted
Gold Super Contributor
Posts: 3,087
Registered: ‎03-19-2009

Chasing the cause of a 412 Precondition Failed error message in Mobility

Most errors are fairly easy to trace down in FF w/FireBug.. but on occasion I've seen a "412" error when attempting to update/change the contents of a record.

 

Specifically, has a contact up and changed the first name & went to save.. and got a 412.

 

Ideas, suggestions, etc?

--
RJ Ledger - rjledger@rjlSystems.net +1 603.369.3047 x101

".. Innovators in Mobility - Experts in Workflow Automation..."
http://www.rjlSystems.net - blog: www.rjlSystems.net/blog.html
Highlighted
Gold Super Contributor
Posts: 3,087
Registered: ‎03-19-2009

Re: Chasing the cause of a 412 Precondition Failed error message in Mobility

Humm.. was able to trace it back to an "ownership" issue. 

 

The Team that owned the account (and contacts) had one user in it. The user had a "Team Owner Profile".. and the team profile was RW default.

 

Changing the Account (and contacts) ownership to another team where the members had "standard" individual R/W profiles solved the issue.

 

.. very strange...

 

Also, the error message (at the Mobility user level) was just an "alert" saying there was a "server error" - nothing else. It was only because I was running in FF w/Firebug on that I saw the "real" message.

 

Seems like a bug to me ..

--
RJ Ledger - rjledger@rjlSystems.net +1 603.369.3047 x101

".. Innovators in Mobility - Experts in Workflow Automation..."
http://www.rjlSystems.net - blog: www.rjlSystems.net/blog.html