Showing results for 
Search instead for 
Do you mean 
Community Home Request Access Read Blogs Share Your Ideas Search Community View My Settings
Reply
Copper Elite Contributor
Posts: 80
Registered: ‎04-16-2009

Problems with Field Security Profiles in the Web client

Read only profile is working in the web client and LAN client as expected.  No Access is working as expected in the LAN client but only half working in the Web.  When a field has No Access and contains data, nothing is displayed in the Web form.  This is as expected.  However, the user can enter their own data and save it.  This is a bug and needs a hotfix soon.

 

Form data is being cached in IE.  If the owner of a record is changed by another user, this isn’t seen in the Web client if it's already been viewed.  It displays the owner properly in a list view, but displays the old owner in the detail view.  The cache needs to be cleared for the new owner to display and affect the security.  I tried turning on InPrivate browsing which is supposed to stop form data caching, but this didn't resolve the problem.

 

Scot

Scot Zimmerman
Interlinx Associates, LLC
szimmerman@interlinxassociates.com
612-669-2145
Bronze Super Contributor
Posts: 153
Registered: ‎04-08-2009

Re: Problems with Field Security Profiles in the Web client

Which version of SLX Web is this?    I reported this issue for 7.5.1, except in my case web users could also read existing values in fields set to "No Access" for them.   I was wondering is this existed in 7.5.2 as well.

 

 

 

 

Copper Elite Contributor
Posts: 80
Registered: ‎04-16-2009

Re: Problems with Field Security Profiles in the Web client

This problem is in 7.5.2.
Scot Zimmerman
Interlinx Associates, LLC
szimmerman@interlinxassociates.com
612-669-2145