Showing results for 
Search instead for 
Do you mean 
Community Home Request Access Read Blogs Share Your Ideas Search Community View My Settings
Reply
Copper Elite Contributor
Posts: 153
Registered: ‎02-27-2010

Hide Groups Grayed Out (7.2.2)

7.2.2 Lan Client (1 user only)

 

Is anyone familiar with a problem where the Hide Groups option is grayed out. The user with the problem can Manage Groups and Hide there but they don't remain hidden at the next login.

 

I went into the Function Security Tab of the User Profile in Admin and removed all MainView functionality which did remove all other Group functionality (like edit, copy and export) and when I re-enabled it, all other fuctionality except for the problematic Hide did come back.

 

I called Sage and they provided a 6.2 document with 3 options

1. Copy Profile

2. Delete Useroptions (back in 6.2, I think there used to be 1 useroption record per user but now there are many)

3. Create new user (way too much work for the minor problem)

 

Does anyone have any recommendations?

 

Thanks,

Larry

Gold Super Contributor
Posts: 3,087
Registered: ‎03-19-2009

Re: Hide Groups Grayed Out (7.2.2)

This is an area where we did some investigation a while ago.. and tech support has pointed you in the correct direction - useroption(s)/profile related.

 

My "gut" is telling me that the db in question was upgraded from a USEROPTION based one to a USEROPTIONS based on.. and the original USEROPTION table was probably "slightly" corrupt (ex: more than one record per user for some users, etc...). - We have a "best practice" procedure we use here: DELETE FROM USEROPTION just before upgrading so that the USEROPTIONS table will be "clean".

 

Even w/amount of "blob breakout" that was done w/USEROPTIONS, there are still blobs that will bite (byte) you.... ;-)

--
RJ Ledger - rjledger@rjlSystems.net +1 603.369.3047 x101

".. Innovators in Mobility - Experts in Workflow Automation..."
http://www.rjlSystems.net - blog: www.rjlSystems.net/blog.html
Copper Elite Contributor
Posts: 153
Registered: ‎02-27-2010

Re: Hide Groups Grayed Out (7.2.2)

RJL,

 

I think your hunch is right. Back in 6.2 it was not uncommon for us to find multiple useroption records for a user that I logged on as to troubleshoot (while they were logged on too) typically causing the duplicate corruption. Unfortunately we didn't exercise your due dilligence in eliminating this condition prior to upgrade - I wasn't even aware of the BLOB breakout (Great Idea!) until after the fact.

 

But it would seem to me, that it should be a simple matter to try to surgically remove the problematic USEROPTION BLOB and if that doesn't work, simply remove them all and let the user restart with the default configuration (better than a corrupt one)! (i.e. There's no problem with deleting all useroption BLOBS for a particular user? It simply removes any/all user customization that had been done?)

 

So my thought is that since there is a MainView BLOB for this user that contains existing HiddenGroups, maybe deleting that record might rectify the problem, or something along those lines. It would seem that Sage should be able to identify where the Hide Group disabling would take place (i.e. which BLOB).

 

The one thing I find a little strange is that Sage has a documented procedure for correcting the grayed out Hide Group option. It's just seems too much of a coincidence: there are hundreds of configuration quirk possibilities but this one has a documented fix?

 

If my efforts with the USEROPTIONS doesn't work, it would seem that Copying a Profile won't help either and I sure as heck ain't gonna create a new user - that has provided tons of headaches in the past.

 

Thanks,

Larry Esposito

 

 

Copper Contributor
Posts: 36
Registered: ‎01-13-2011

Re: Hide Groups Grayed Out (7.2.2)

Here we are 2 years later and I have the same problem. Some user have the ability to hide from the RMB menu and others do not. Sill no entry in the Feature Security. Purginf the UserOption/s tables does nothing. I am on 7.5.2. Anyone figure this out yet?

Steve Meyers
Lead Software Developer, Business Software Applications
Promega Corporation
2800 Woods Hollow Rd
Madison, WI 53711-5399
steve.meyers@promega.com
www.promega.com
Copper Contributor
Posts: 36
Registered: ‎01-13-2011

Re: Hide Groups Grayed Out (7.2.2)

If anyone is interested in this, I have discovered the issue and corrected it.

 

Delete From UserSecFunctions Where LTrim(RTrim(Coalesce(FunctionName,''))) = ''

Steve Meyers
Lead Software Developer, Business Software Applications
Promega Corporation
2800 Woods Hollow Rd
Madison, WI 53711-5399
steve.meyers@promega.com
www.promega.com