Showing results for 
Search instead for 
Do you mean 
Community Home Request Access Read Blogs Share Your Ideas Search Community View My Settings
Reply
Employee
Employee
Posts: 23
Registered: ‎08-27-2009

'Export to file' does not work

HI there,

 

I login onto the server via web client with admin account. After clicking 'Export to file', i will get a csv file without any records. The file contains only several columns name.  I am using SLX 7.5 and Office 2007. DO i miss something?

 

Thanks in advance! 

Bronze Elite Contributor
Posts: 514
Registered: ‎03-24-2009

Re: 'Export to file' does not work

I'm assuming you have tried to replicate the same issue using different: Groups, SalesLogix user, Windows User, Workstation?

 

Regards, Adam Travers
empath-e Services Limited
Highlighted
Tuned Listener
Posts: 16
Registered: ‎04-02-2009

Re: 'Export to file' does not work

Also ensure that your site is a Trusted Site and the security settings for Trusted Sites is set to Low.

 

 

New Member
Posts: 2
Registered: ‎05-03-2012

Re: 'Export to file' does not work

[ Edited ]

I'm having the same issue, did anyone find a resolution to this?

 

I noticed that each time I attempt an export, an error is logged on the web server's Event Viewer, e.g.:

 

2012-05-03 14:03:34,014 [3] WARN  OutputWindow - User: U6UJ9A000053 Received: Thread was being aborted.

 

To answer the previous responses to the original question, this was reported by another user here (we're just starting out with the Web Client) and I've attempted it with different groupings, to the same effect.

 

Changing IE security settings did not make any difference, as I would have suspected; the file is being sent from the server to the client PC just fine, it's just that it's empty! Having said that, if I choose to export the file in a tab-delimited format, the file does contain something:

 

ÿþ

I'm guessing this is a tab character, in any event it's certainly not my data.

 

Can anyone assist?

New Member
Posts: 2
Registered: ‎05-03-2012

Re: 'Export to file' does not work

[ Edited ]

For anyone still wanting a fix for this, I have one!

 

In Visual Studio I stepped through the export method in SmartParts\TaskPane\CommonTasks\CommonTasksTasklet.ascx.cs -> ExportToFile.

 

I was surprised to see that the data I requested was actually being returned into this method's DataTable 'GroupTableAll'.

 

In short, the SetLayout method called in ExportToFile was hiding every single column, which is why I was getting no data. I just commented out this call and I'm now getting my data.

 

Hope this helps others.

 

 

EDIT: I just noticed that the original poster was getting the headings but no data. This is different to my issue. I'm not sure if it's helpful to anyone but at least this fix exists.