Showing results for 
Search instead for 
Do you mean 
Community Home Request Access Read Blogs Share Your Ideas Search Community View My Settings
Reply
Copper Elite Contributor
Posts: 153
Registered: ‎02-27-2010

Admin User Profile Navigation Slow (v7.2.2)

When we upgraded to 7.2.2 I had immediately noticed that opening the User Profile and moving from user to user took much longer than 6.2.6 (20 secs instead of 5). Configuration changes for our 200 users was already a challenge without the extra wait navigating between them. While talking to Sage recently, I mentioned the issue and they said perhaps the number of Groups is contributing to the delays. After painstaking testing I confirmed their hunch. In a stroke of genius, I realized that I could simply add a new functional admin (concurrent) user with no teams (i.e. no Groups except those few released to Everyone) and sure enough, I got the response back to the days of 6.2.6 (5 secs) without removing any Groups. My question(s): 1. What led this top notch Sage Tech to point to the Groups? 2. Why would Groups impact navigation between users? 3. What happened between 6.2.6 to 7.2.2 that caused the new delays? (We actually had more Groups in 6.2.6) Fortunately, I answered my most important question of a possible workaround but I am curious about this new issue that had frustrated me for nearly 2 years. Thanks, Larry Esposito
Copper Elite Contributor
Posts: 153
Registered: ‎02-27-2010

Re: Admin User Profile Navigation Slow (v7.2.2)

Postscript

 

Although my workaround works for most needs, I don't believe it works for cutting remotes since I believe one can only cut a remote with data that one has access too. I found this out a while back (perhaps prior to 7.2.2) because I had 2 IDs with different team access and when accidentally using the wrong ID, no data was in the newly cut remote!

 

And I suspect there will also be an issue with assigning default Groups for similar reasons, at least that's what I'm seeing with this new ID.

 

P.S. Sorry for the original lack of formatting - I had forgot to switch to Rich Text. I was also frustrated trying to post a quick reply. It gave me some kind of error.

Copper Elite Contributor
Posts: 153
Registered: ‎02-27-2010

Re: Admin User Profile Navigation Slow (v7.2.2)

I also can't assign Main View Default Groups since an Admin assigned to no Teams has no access to Forms that aren't released to Everyone. It would be nice if there was some indexing that could be done on the Group Lists since the delays are proportional to the number of Groups I have out there. It's tough enough managing the 200+ users without the 30 second delay moving to the next user. Thanks, Larry Esposito
Copper Elite Contributor
Posts: 33
Registered: ‎08-05-2009

Re: Admin User Profile Navigation Slow (v7.2.2)

Did you try running SLX Profiler in order to see the differences of the SQL statements between the different users when opening the Administrator and which statement takes too long to execute?

 

If you find out which statement(s) takes the extra 15 seconds to execute you can optimize the query perhaps using the SLX Profiler.

 

Regards,

 

Hartog Elands

Copper Elite Contributor
Posts: 153
Registered: ‎02-27-2010

Re: Admin User Profile Navigation Slow (v7.2.2)

I did try running SLX Profiler but even when I knew the answer, or so I thought, (number of Groups), I could not discern it from the Profiler logs.

 

Thanks,

Larry Esposito