Showing results for 
Search instead for 
Do you mean 
Community Home Request Access Read Blogs Share Your Ideas Search Community View My Settings
Reply
Bronze Super Contributor
Posts: 146
Registered: ‎04-01-2009

7.5.4 LAN, slxab32.dll, slmn.dll, Windows 7, and Outlook 2010

Hi folks,

 

So I am running 7.5.4 LAN (eval database for now), Windows 7 (64-bit), and Office 2010 including Outlook 2010 (32-bit). 

 

The first issue I found is that I didn't have the Outlook integration after I ran the install. So, I registered both slxab32.dll and slmn.dll.  Then I opened Outlook. Outlook thought about it, but then gave up with the "This program has sopped working" message.   After a few pokes and shoves, I determined that slxab32.dll was the one causing the problem.

 

With it uninstalled, Outlook opened just fine, but I didn't have my SendSLX buttons and such.  Looking in the Add-ins section of Outlook 2010's Help, I saw that slmn.dll was "enabled" but was listed as"Inactive". So a opened up the Enabled group, and saw that although slmn.dll was registered, and enabled, that it was not set to load when Outlook started. Putting a check in that check box fixed that, and the next time I opened Outlook, I had my SendSLX buttons, etc. That part is good.

 

Still I couldn't get Outlook to launch when slxab32 was registered.  What I eventually found was that if I launched SalesLogix first, SalesLogix would take 10 seconds to open up, but, I would get windows 7's spinning circle (the new hour glass) and I will not get control of the application for 2 minutes and 40 seconds. (auto Log onto email is set to yes). Turns out that SLX is more patient in opening outlook then windows 7 is.  What looked like a critical failure on opening Outlook directly was just Windows timing out waiting for it to respond.

 

Now, if I open Outlook, it opens....slowly, but it opens. Takes about 25 seconds. When I look for my SLX address book in Outlook, it is there.  So, the dll's are registered and they work, but slmn.dll is interacting with Outlook in a way that brings it to its knees when opening. 

 

Any thoughts on what to do here?  Where to poke next?

 

Thanks

 

Patrick

Bronze Elite Contributor
Posts: 514
Registered: ‎03-24-2009

Re: 7.5.4 LAN, slxab32.dll, slmn.dll, Windows 7, and Outlook 2010

Hi,

 

Try registering both dll's using 'Run As Administrator'  option on the command prompt. If that does not resolve the issue try dropping or disabling UAC and see if that helps?

Regards, Adam Travers
empath-e Services Limited
Highlighted
Bronze Super Contributor
Posts: 146
Registered: ‎04-01-2009

Re: 7.5.4 LAN, slxab32.dll, slmn.dll, Windows 7, and Outlook 2010

Thanks for the reply Adam.  Tried both suggestions and still have the same result. :-( 

 

What was your thinking on the UAC bit?  We do have software installed called Avecto Privilege Guard which also limits access to PC resources.  Similar to UAC.  I can't disable that, so I'll need to have some theory to give to the network gods as a sacrifice.

 

Thanks

 

Bronze Elite Contributor
Posts: 514
Registered: ‎03-24-2009

Re: 7.5.4 LAN, slxab32.dll, slmn.dll, Windows 7, and Outlook 2010

That might be worth looking in to. Do you have a test machine without it installed?

 

Also, I have just found this on the SLX KB - Might be worth a look. First, I would unregister the slxab32.dll and leave the slmn.dll registered. If the problem does not occur then you know it is the slxab32.dll causing the issue as below..?

 

Description:

Outlook takes several minutes to open when SalesLogix integration is enabled.

Example:  Outlook takes anywhere from three to ten minutes to open when Send to SLX and SalesLogix address book functionality (slmn.dll and slxab32.dll) are enabled.

 

Possible Resolution:

This issue can be caused by problems with Contact groups.
Example:  A corrupt group may be released to the affected user(s), or a group with an excessive number of conditions (30+) may exist.

 

To resolve the issue, unrelease custom groups to the affected user(s) to determine which is causing the issue, then examine the group for problems.

Regards, Adam Travers
empath-e Services Limited
Copper Contributor
Posts: 17
Registered: ‎04-08-2009

Re: 7.5.4 LAN, slxab32.dll, slmn.dll, Windows 7, and Outlook 2010

I've got the exact same problem and tried all of the above. In fact I don't have any Contact Groups left but do have Account Groups. Could that be the same issue?

 

For now I've got in to Outlook just by removing the SalesLogix Address Book from the account settings.

 

BTW I don't have the "Go To SalesLogix" button any more.

Paul Cannon
Fisher Technology
Bronze Super Contributor
Posts: 146
Registered: ‎04-01-2009

Re: 7.5.4 LAN, slxab32.dll, slmn.dll, Windows 7, and Outlook 2010

Hi Paul,

 

I still don't have a solution for this.  I am fine when I register slmn.dll, and un-register slxab32.dll.  I don't have my contact groups available in my Outlook address books, but do have the Send SLX, Record to History, etc. They all work fine.  You might check in Outlook under File (tab) --> Options --> Add-Ins, and make sure that slmn.dll is not inactive or disabled.

Gold Super Contributor
Posts: 3,087
Registered: ‎03-19-2009

Re: 7.5.4 LAN, slxab32.dll, slmn.dll, Windows 7, and Outlook 2010

slxab  is just for the address book.. all other functionality is handled by the slmn dll and some code in the "Global Scripts" (in WIndows/LAN clients). 

--
RJ Ledger - rjledger@rjlSystems.net +1 603.369.3047 x101

".. Innovators in Mobility - Experts in Workflow Automation..."
http://www.rjlSystems.net - blog: www.rjlSystems.net/blog.html
Copper Contributor
Posts: 17
Registered: ‎04-08-2009

Re: 7.5.4 LAN, slxab32.dll, slmn.dll, Windows 7, and Outlook 2010

Thanks Patrick, I re-registered the DLL's again making sure I was running the command prompt 'as administrator' and Outlook still doesn't load, unless I remove the SalesLogix Address Book from the Mail Profile, or disble the add-ins. I do have Send SalesLogix and Record to History and they work fine (to the main recipient, not the cc or bbc recipients), but no Go To SalesLogix button.

 

Is this a common problem?

 

BTW I have not yet applied any hotfixes to my 7.5.4 system.

Paul Cannon
Fisher Technology
Tuned Listener
Posts: 2
Registered: ‎04-14-2009

Re: 7.5.4 LAN, slxab32.dll, slmn.dll, Windows 7, and Outlook 2010

I have the same issue with Win7 64 Bit, Outlook 2010 (32bit).  If I register SLXab32.dll (salesLogix address book) Outlook tries to start but returns a message that "Microsoft Outlook has stopped working" within 20 seconds.  If I unregister this dll, outlook will start up fine but I don't have my SalesLogix Address Book (obviously).  I had been using Win7 64 bit with Outlook 2007 until yesturday and the SalesLogix Address book had worked fine.

 

Has there been any other actions discovered to address this problem?

Copper Contributor
Posts: 17
Registered: ‎04-08-2009

Re: 7.5.4 LAN, slxab32.dll, slmn.dll, Windows 7, and Outlook 2010

[ Edited ]

I've rolled-back to Outlook 2007 and everything now works great.

 

I don't know why the integration doesn't in Outlook 2010 but since it doesn't offer me any great advantage over 2007 I'm not too concerened.

 

But going forward, this must be a fixable issue.

Paul Cannon
Fisher Technology