Showing results for 
Search instead for 
Do you mean 
Community Home Request Access Read Blogs Share Your Ideas Search Community View My Settings
Reply
Copper Super Contributor
Posts: 26
Registered: ‎08-08-2013
Accepted Solution

Speedsearch Issue on Citrix Environment

Hi all,

 

we have a client with citrix environment and SLX 8.0 LAN.

 

If they click to open the speedsearch window we retrieve the message: "failed to initialize"

The Speedsearch window opens. Searching is possible and results in the list are shown.

 

But no preview displays and the message pops up:

Preview for <Entity> <ID> can not be displayed. Error: File access denied. (freely translated from the German system)

 

No matter what entity - contact, account, attachment ...

Speedsearch on the server works as expected.

 

Does anyone know which rights could be missing?

 

thanks.

Bronze Super Contributor
Posts: 113
Registered: ‎07-27-2009

Re: Speedsearch Issue on Citrix Environment

Hi,

 

just tested this in our environment. Same error.

 

Is drive C: visible or is it hidden on the Citrix-Server?

 

Regards
Rainer Raebiger
Copper Super Contributor
Posts: 26
Registered: ‎08-08-2013

Re: Speedsearch Issue on Citrix Environment

thanks for reply.

 

c: is hidden for the users.

Bronze Super Contributor
Posts: 113
Registered: ‎07-27-2009

Re: Speedsearch Issue on Citrix Environment

Same here. I think this is the problem. SpeedSearch creates a html-file to show the preview of a result. You can find it under C:\Program Files (x86)\SalesLogix\SpeedSearch\Bin\Blank.htm

 

I think SpeedSearch-Client does not "see" drive C:

Regards
Rainer Raebiger
Copper Super Contributor
Posts: 26
Registered: ‎08-08-2013

Re: Speedsearch Issue on Citrix Environment

I thought about a local, temporary file but wasn't sure, thanks Smiley Happy

Maybe i can argue our client to ease their restrictions for testing. Then i can tell more.

Copper Super Contributor
Posts: 26
Registered: ‎08-08-2013

Re: Speedsearch Issue on Citrix Environment

Hello Rainer,

 

just a short update:

in our case, the error was caused by missing rights on the program files folder. Now the Speedsearch also works on citrix with hidden drive C:.

 

best regards

AWollner

Bronze Super Contributor
Posts: 113
Registered: ‎07-27-2009

Re: Speedsearch Issue on Citrix Environment

Thanks for sharing André.

Regards
Rainer Raebiger