Showing results for 
Search instead for 
Do you mean 
Community Home Request Access Read Blogs Share Your Ideas Search Community View My Settings
Reply
Highlighted
Silver Super Contributor
Posts: 801
Registered: ‎03-24-2009

SLXBuild & SNC Updates for Saleslogix v8.0

Beware creating a build of SLX for LAN/Windows installation - this works in the main. However, starting with v8.0 the SLX OLEDB provider cannot be merged into a build (SNC 06/09 for example). With 06 - it says there is nothing to update (so you ignore it). With 09 - it proceeds to update but only does so partially. You cannot, therefore, rely on the build. Or, you can get it to install most - and then install 06/09 manually after. This is most likely to also effect v8.1.
Highlighted
Bronze Super Contributor
Posts: 265
Registered: ‎04-14-2009

Re: SLXBuild & SNC Updates for Saleslogix v8.0

Hi Mike,

 

Ran into this, not sure if you are aware this is obviously a bug but there is a workaround, you have to update the individual MSI's for the OLEDB provider, details below.

 

Issue #: Defect 13092312

 

Symptom: 

When trying to apply SLX 8.0 SNC Update 01 to a SalesLogix Network Build the warning message 'That file is not applicable to this update' will appear.

Expected Behaviour:

SNC Update 01 updates the SLX OLE DB Provider and this will work correctly if applying the hotfix to a server or client install.

Should also update the SLX OLE DB Provider for a Network Build image as well, but does not correctly identify that the provider need to be updated.

 

Cause or Steps to Reproduce: 

 

1.

Run the SLX_v800_Update_01.exe

2.

Either choose to install the update or unpack it to a local folder

3.

Select ‘Update Network Images’

4.

Click ‘Add Path’

5.

Go to the folder containing the Network Image and select the ‘Sage SalesLogix Network Client.msi’

6.

Click Open

7.

Click Update

8.

‘That file is not applicable to this update’ message is show

9.

Follow steps 2-8 with Update 06 and receive the same message

 

Solution or Workaround or Status: 

Note, Special Considerations, or Warning:

The workround for this is to directly update the Sage SalesLogix OLE DB Provider.MSI

 

1. Run the SLX_v800_Update_01.exe

2. Either choose to install the update or unpack it to a local folder

3. Select ‘Update Network Images’

4. Click ‘Add Path’

5. In the Network Client folder, go to: \ISSetupPrerequisites\{3E094704-089F-4D49-98E9-94AF30E3ADA9}\

6. Select the ‘Sage SalesLogix OLE DB Provider.msi’

7. Then click ‘Update’

8. Allow the update to complete

 

Regards

Craig

Highlighted
Silver Super Contributor
Posts: 801
Registered: ‎03-24-2009

Re: SLXBuild & SNC Updates for Saleslogix v8.0

Thanks Craig - very very useful to know. Also means this needs to be applied for Update09 as well (as that also now updates the provider too). Don't suppose you have a fix for the Office issue do you :-)
Highlighted
Silver Super Contributor
Posts: 801
Registered: ‎03-24-2009

Re: SLXBuild & SNC Updates for Saleslogix v8.0

Unfortunately, it doesn't work - I de-installed and deleted c:\pf\slx and then applied the SNC updates (06 & 09) as per the instructions - the installer appeared to update the network image (as opposed to giving the error as before). I then ran the build on the PC. Post install - same issue - the versions of provider pieces are still .8479 (original). The controls however are .8636 (09). Can you check one of your clients - did their builds work and update ?
Highlighted
Bronze Super Contributor
Posts: 265
Registered: ‎04-14-2009

Re: SLXBuild & SNC Updates for Saleslogix v8.0

Hi Mike,

 

Worked for me when creating the automated build, checked the versions afterwards, from memory I believe you effectively have to run it twice, once to update the nework image and once to update the provider, it has been a while but believe this was the case.

 

Sorry which office issue are you referring to?

 

Regards

Craig

Highlighted
Silver Super Contributor
Posts: 801
Registered: ‎03-24-2009

Re: SLXBuild & SNC Updates for Saleslogix v8.0

[ Edited ]

Yes, I had already run it once (this is SNC09) to update the build generally.

 

Then updated the MSI individually as per your instructions. The result is still the original for me. Update 09 (.8636) is the latest SNC with the provider components (+Admin & Architect, Saleslogix exe) - but these are subsequently updated with SNC13 and SNC14.

 

Are you sure you are updated to 09?

 

Edit: You can also see in the .CAB in the same folder (ISS) - this is the old version, if you extract the pieces, they aren't updated. Still .8479.

Highlighted
Bronze Super Contributor
Posts: 265
Registered: ‎04-14-2009

Re: SLXBuild & SNC Updates for Saleslogix v8.0

Mike,

 

Our build has 06 and 09 in it and am 99.9% certain it updated correctly, will try and run it up to ensue it is correct.

 

Regards

 

Craig

Highlighted
Silver Super Contributor
Posts: 801
Registered: ‎03-24-2009

Re: SLXBuild & SNC Updates for Saleslogix v8.0

If you could, that'd be great. Sorry to be a pain, but would be good to have a working build and know the issues (plus, you may find yours aren't updated - as you don't actually notice any difference, the client appears to work fine of course!).

 

You can quickly check versions here:

 

http://www.empath-e.com/support/SLXVersions.txt

 

This has the versions if you search for "SalesLogix v8.0.0 (Gold 06/12/2012)" - shows the dll/exe from original to SNC14.

 

Highlighted
Bronze Super Contributor
Posts: 265
Registered: ‎04-14-2009

Re: SLXBuild & SNC Updates for Saleslogix v8.0

Mike,

 

My build shows it as 8.0.0.8600 I seem to recall at the time of building there was some sort of discrepancy which had me checking things, I believe this was it, as looking at another machine which has been manually installed and updated including 09 the SLXOLEDB.DLL is still the same version 8.0.0.8600. So I don't believe the version was incremented between 06 & 09.

 

All my images show the same version and they all have 09 installed.

 

Regards

Craig

Highlighted
Silver Super Contributor
Posts: 801
Registered: ‎03-24-2009

Re: SLXBuild & SNC Updates for Saleslogix v8.0

Yes, the provider pieces are .8600 (dlls) - it's the controls (.ocx) that go to .8636

 

But, I'm still intrigued as to how you managed to go from .8479 to .8600

 

SLXOLEDB.dll 8.0.0.8479 1,343,488 28/11/2012 08:00:00

SLXOLEDB.dll 8.0.0.8520 1,347,584 31/01/2013 08:00:00 HF02

SLXOLEDB.dll 8.0.0.8600 1,347,584 16/04/2013 08:00:00 HF06

 

As mine steadfastly refuses to do so. Ah well.