Showing results for 
Search instead for 
Do you mean 
Community Home Request Access Read Blogs Share Your Ideas Search Community View My Settings
Reply
Highlighted
Bronze Super Contributor
Posts: 265
Registered: ‎04-14-2009

Re: SLXBuild & SNC Updates for Saleslogix v8.0

Hi Mike,

 

Just hecked and the SLXControls.ocx and some others are 8636, unfortunatley as I say it was some time ago when I went through this but from memory, just ran the update twice for each and browsed to the msi for the provider.

 

I can't recall doing anything else if I look in the Network Client\ISSetupPrerequisites\{3E094704-089F-4D49-98E9-94AF30E3ADA9}\program files\SalesLogix then I see the relevant components at the correct versions.

 

Sorry I can't advise further as off te top of my head I really don't recall doing anything else.

 

Regards

Craig

Highlighted
Silver Super Contributor
Posts: 801
Registered: ‎03-24-2009

Re: SLXBuild & SNC Updates for Saleslogix v8.0

That's interesting. I just checked the folder and a NEW folder has just appeared under the ISSetupPrerequisites\{3E094704-089F-4D49-98E9-94AF30E3ADA9}\program files\Saleslogix dated today. I'm going to re-run it and see what happens this time. My worry is that the provider.cab has the old files in it - and I wonder if they come from there or not. Watch this space !
Highlighted
Silver Super Contributor
Posts: 801
Registered: ‎03-24-2009

Re: SLXBuild & SNC Updates for Saleslogix v8.0

Yep, no difference - the files come out the cab - not the folders.
Highlighted
Bronze Super Contributor
Posts: 265
Registered: ‎04-14-2009

Re: SLXBuild & SNC Updates for Saleslogix v8.0

Hi Mike,

 

Just checked this again and the latest updates in the Network Client\ISSetupPrerequisites\{3E094704-089F-4D49-98E9-94AF30E3ADA9}\program files\SalesLogix are 8600 apart from profiler which is 8636.

 

However in the Network Client\program files\SalesLogix the  following are 8636

SLXControls.OCX

SLXMMEngine.dll

SLXMMGUI.dll

SLXsearchTrigger.dll

 

The Saleslogix.exe is 8689

 

So can't explain what is going on with yours, but my build appears to be correct and does deploy the correct versions.

 

Regards

Craig

 

Highlighted
Silver Super Contributor
Posts: 801
Registered: ‎03-24-2009

Re: SLXBuild & SNC Updates for Saleslogix v8.0

[ Edited ]

Yes, you are right - and mine shows exactly the same.

 

However, if you look in PROVIDER.CAB in the root ISSetupPrerequisites\{3E094704-089F-4D49-98E9-94AF30E3ADA9} You will notice this is the compressed set of files - being the old versions.

 

You can ignore the program files\Saleslogix under here - it's not used. You can prove that by deleting the folder and the install will still  work. If you delete the provider.cab - the install will NOT work.

 

Now, that said - I also get an intellisync error at the very end of the build install. I've ignored that previously as I didn't think it was relevant. My thinking is now shifting to something else. If you don't see this error (I didn't build the install originally w/intellistink so it won't be there - that's what I suspect this error is showing). But, maybe AFTER this error it would ordinarily go onto copying the files from ISSetupPrerequisites\{3E094704-089F-4D49-98E9-94AF30E3ADA9}\program files\saleslogix (i.e. the new ones) over the top. Perhaps this is why it works - my install fails to update due to the error of intelli.

 

If you have the time, could you prove that theory for me? Rename the folder ISSetupPrerequisites\{3E094704-089F-4D49-98E9-94AF30E3ADA9}\program files\saleslogix (to something like ISSetupPrerequisites\{3E094704-089F-4D49-98E9-94AF30E3ADA9}\old) so the installer can't find it. Re-run the build on a new machine (or one that has had slx de-installed) and tell me what happens - do you get an error at the end (as it can no longer find the folder for the new binaries) or does it install OK - but minus the updates?

 

Similarly, if you can then de-install, rename the folder back, and re-install. Does it then put the right versions on?


Finally, can you confirm that provider.cab in ISSetupPrerequisites\{3E094704-089F-4D49-98E9-94AF30E3ADA9} is outdated (drag out slxoledb.dll to desktop and compare the version).

 

THANKS CRAIG!