Showing results for 
Search instead for 
Do you mean 
Community Home Request Access Read Blogs Share Your Ideas Search Community View My Settings
Reply
Copper Contributor
Posts: 56
Registered: ‎02-22-2012

SLX 8: Web Reporting has not been configured

[ Edited ]


After installing/configuring SalesLogix and the Web Reporting, when I log in to the SlxClient and clik on the Reports navigation item, the page oshows the following text instead of the reports:

Web Reporting has not been configured. Please contact your SalesLogix Administrator.


I'm using:
* SalesLogix v8 RC 3.
* Windows 2008 R2 Datacenter 64 bits
* The Crystal Reports that is shipped with SLX 8rc3:
  - Crystal Reports XI Release 2 (11.5.10.1263)
  - Crystal Reports Server Embedded Edition (11.5.10.1275)

What I've done so far:

I have installed Crystal Reports and the SLX Web Reporting software following the Implementation Guide for SalesLogix 8. I was logged in as the local Administrator user. I have also checked older implementation guides and course manuals to check for missing configuration steps (e.g. the Web Dependency is not specified in the SLX 8 Implementation Guide).

I have checked the "ServiceHosts.xml" file in the SlxClient deployment folder as stated here and the URL is OK:
http://community.sagesaleslogix.com/t5/Administration/Problem-with-Crystal-reports-Server-settings/m...

If I go to the Web Reporting URL (http://localhost:3334/slxwebrpt), I get the following text, which I believe this means it's up and running:
You have accessed the Default Services Page and should not be here

 

Is there anything else that is not in the implementation guide? Are there any log files that I can check (the Event Viewer has no error messages)?

 

Regards,

 

     Marcos

 

Silver Contributor
Posts: 835
Registered: ‎03-24-2009

Re: SLX 8: Web Reporting has not been configured

Did you build and deploy the web portal? (yes I'm grasping at straws....installing the web reporting stuff has always been a problem for me......always).

RJ Samp
Copper Contributor
Posts: 56
Registered: ‎02-22-2012

Re: SLX 8: Web Reporting has not been configured

Yes, I have built/deploy many times with different combinations... It's a pain in the *ss...

Employee
Posts: 629
Registered: ‎04-24-2009

Re: SLX 8: Web Reporting has not been configured

What does the contents of SlxClient\ServiceHosts.xml look like?

 

Thanks

 

Mike

Copper Contributor
Posts: 56
Registered: ‎02-22-2012

Re: SLX 8: Web Reporting has not been configured

I finally installed Web Reporting in SLX 8.

I uninstalled all the v8 RC3 software and installed from scratch using v8 Gold.

 

Tip: deploy the slxwebrpt portal in the default location (C:\inetpub\wwwroot). Otherwise, SalesLogix will not find the Web Reporting.

 

Regards,

 

      Marcos