Showing results for 
Search instead for 
Do you mean 
Community Home Request Access Read Blogs Share Your Ideas Search Community View My Settings
Reply
Tuned Listener
Posts: 15
Registered: ‎08-25-2009

Remote Office plugin synchronization

We have a problem with Sales Logix remote office synchronization. 

We customize the form  Contact:Tickets and this form correctly work in main office. This form released for everyone but users see old form on the remote office. We do not have record In table "plugin" of remote office for new plugin.

SLX version 7.5.0. LAN.

 

 

 

 

 

 

 

Silver Contributor
Posts: 1,262
Registered: ‎04-08-2009

Re: Remote Office plugin synchronization

Does the sync in general works?

So do get other changes sync to the remote office, like changes of accounts...?

What happens if you create a new group, is this synced out to the remote office?

Are there any sync errors on the server or client, are all outfiles pulled from the server to the remote office?

 

Did the users do a refresh of the client?

 

Thanks! Alexander

Tuned Listener
Posts: 15
Registered: ‎08-25-2009

Re: Remote Office plugin synchronization

Synchronization for new accounts and change accounts work correctly. 

New created group transfered to remote office.

The no sync errors with sync.

 

 

Tuned Listener
Posts: 4
Registered: ‎04-17-2009

Re: Remote Office plugin synchronization

I'm running into the same problem on a test environment that's on 7.2. Normal sync works fine, network client sees the updated plugins fine. If I cut a new remote database the remote client gets the updated plugin. I have the shared directories all set to Everyone with full permissions (it's an isolated test environment--no security issues to worry about).
Silver Contributor
Posts: 1,262
Registered: ‎04-08-2009

Re: Remote Office plugin synchronization

Can you see that files are changed or created in the WGLogs folder?

When you release a plugin, this I think should result in some changes in that folder.

 

Do you have any errors in the syncerrors.txt or event log?

 

Thanks! Alexander

Tuned Listener
Posts: 4
Registered: ‎04-17-2009

Re: Remote Office plugin synchronization

No syncerrors.txt files on the app server. There are a bunch of errors in the event log, which boil down to these two getting repeated a lot:

 

Event Type: Error
Event Source: SLXSyncService
Event Category: None
Event ID: 4
Date:  9/25/2009
Time:  12:00:07 PM
User:  N/A
Computer: SLX-NTAPP1
Description:
Error creating history record.  I/O error 103

Event Type: Error
Event Source: SlxSyncServer
Event Category: None
Event ID: 4
Date:  9/25/2009
Time:  1:00:08 PM
User:  N/A
Computer: SLX-NTAPP1
Description:
The description for Event ID ( 4 ) in Source ( SlxSyncServer ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: You cannot load more than one copy of SyncServer at a time..

I'm not really sure what to be looking for in the WGLogs. There are several files, all show as being accessed the last time I ran the SyncServer. I just ran it again, and only one file was accessed.

Highlighted
New Member
Posts: 1
Registered: ‎06-11-2009

Re: Remote Office plugin synchronization

This is a known issue with remote offices when releasing plugins to Everyone.

Release to a Group instead of Everyone.

Tuned Listener
Posts: 4
Registered: ‎04-17-2009

Re: Remote Office plugin synchronization

That made no difference. I did some more digging (and really read the sync client messages). I suspect that I'm getting no connection to the FTP server in my little test environment. Here's my last synch attempt output:

 

-[10/6/2009 2:30:31 PM]      Closing current log file.
-[10/6/2009 2:30:32 PM]      Sync process started...
-[10/6/2009 2:30:35 PM]      Successful connection to 10.1.2.245
-[10/6/2009 2:30:35 PM]      Preparing to compress and send outfiles.
-[10/6/2009 2:30:35 PM]      Getting files from: C:\Documents and Settings\All Users\Application Data\SalesLogix\Sync\Outfiles\*.JGO4
-[10/6/2009 2:30:35 PM]      Getting files from: C:\Documents and Settings\All Users\Application Data\SalesLogix\Sync\Outfiles\ZIP-*.JGO4
-[10/6/2009 2:30:35 PM]      No files sent.
-[10/6/2009 2:30:36 PM]      No files received.
-[10/6/2009 2:30:36 PM]      Getting files from: C:\Documents and Settings\All Users\Application Data\SalesLogix\Sync\Infiles\*.RZOA
-[10/6/2009 2:30:36 PM]      Removing old history records...
-[10/6/2009 2:30:48 PM]      Applying changes...
-[10/6/2009 2:30:48 PM]      Begin pending attachment files
-[10/6/2009 2:36:45 PM]      Completed pending attachment files
-[10/6/2009 2:36:48 PM]      No changes are available to apply.
-[10/6/2009 2:36:48 PM]      Sending error files...
-[10/6/2009 2:36:48 PM]           20090827 144158602.RZOA:  Failed to send file. The connection with the server was reset
-[10/6/2009 2:36:48 PM]      Notifying SpeedSearch Service to refresh its Indexes and Schedules.
-[10/6/2009 2:36:50 PM]      FTP Sync process completed.

 

I notice that there is no file movement at all. There should be as I made a small change to a plugin, released it, and ran the sync server. I looked & found several new *.JGO4 files--I presume those are supposed to go to the client. I obviously have something misconfigured, or am missing a step.

Tuned Listener
Posts: 4
Registered: ‎04-17-2009

Re: Remote Office plugin synchronization

Did some more poking & got rid of the connection reset message. However, I'm still not getting the updates through. I noticed in the status bar on the sync server it shows a path of C:\Documents and Settings\All Users... in the test environment, however on the live server it shows C:\SLXSync. What is this setting from and how do I change it?
Tuned Listener
Posts: 15
Registered: ‎08-25-2009

Re: Remote Office plugin synchronization

I have little more additional information. 

Record in table "sysdba.PLUGIN" with new plugin is present. But values of fields "RELEASED" and "DEV" in this record is "F". Therefore new plugin not work in remote office.