Showing results for 
Search instead for 
Do you mean 
Community Home Request Access Read Blogs Share Your Ideas Search Community View My Settings
Reply
Highlighted
Tuned Listener
Posts: 50
Registered: ‎02-09-2010

JS Script Error IE10

Hi,

 

I have an OOTB v8 with all the latest updates, working fine on FireFox and Chrome.

 

I get errors when trying to use query builder on groups in IE10 though, any ideas? All scripts enabled, trusted sites, etc, etc.

 

Thanks for the help.

 

 

Message: xhrFailed Line: 2 Char: 3100 Code: 0 URI: http://localhost:3333/slxclient/Libraries/dojo/dojo/dojo.js

 

 

Nik

 

 

Highlighted
Tuned Listener
Posts: 50
Registered: ‎02-09-2010

Re: JS Script Error IE10

So I've found the error, I debugged the js was calling this -  'c:\\inetpub\\wwwroot\\SlxClient\\jscript\\Sage\\Utility\\nls\\en-gb\\Sql.js', and was 404'ing.

 

When I actually looked at the folder location 'en-gb' did not exist, however 'en' did, I renamed it and hey presto it worked. Obviously a localisation setting somewhere, I'm now looking into why.

 

Highlighted
Tuned Listener
Posts: 50
Registered: ‎02-09-2010

Re: JS Script Error IE10

Obviously I know that this isn't the way to go and we need an en-gb folder in it's own right but I'm curious to know what has caused this and why the folder isn't there or why it doesn't set up as 'en' otherwise?
Highlighted
Employee
Posts: 44
Registered: ‎08-19-2009

Re: JS Script Error IE10

Hi Nick,

 

I've seen something similar to this, where-by the Query Builder window shows blank screens for the Entity and fields.

 

I also found that SLX was trying to find the SQL.js script in the en-gb folder.  Again creating this directory fixed the issue, but there is no indication of why this happened in the first place.

 

I've raised this issue with US support for investigation.

 

If we identify why this is happening I'll post it on the forum.

 

 

Regards,

Highlighted
Bronze Super Contributor
Posts: 176
Registered: ‎04-28-2009

Re: JS Script Error IE10

[ Edited ]

Hi Everybody,

any news on this issue? It looks like when the browser language is set to non english, e.g. de-ch (swiss-german) it's also looking for this folder which does not exist. Creating it manually fixes the behaviour but we can't do this for all possible set browser languages.

---------------------------
Ambit AG, Switzerland
Highlighted
Bronze Super Contributor
Posts: 176
Registered: ‎04-28-2009

Re: JS Script Error IE10

The Query Builder issue is tracked unter Defect ID 13092451.
---------------------------
Ambit AG, Switzerland
Highlighted
Employee
Posts: 44
Registered: ‎08-19-2009

Re: JS Script Error IE10

[ Edited ]

Hi Nik,

 

The issue with the Query Builder has now been assigned a defect number.

Defect - 13092482

 

Currently this defect is being verified by QA and then this has been done Dev can work on a fix.

At that point we should get an idea of which hotfix or version it will be fixed in.

 

 

Kind regards,

Highlighted
Tuned Listener
Posts: 50
Registered: ‎02-09-2010

Re: JS Script Error IE10

Thank you for the update.