Showing results for 
Search instead for 
Do you mean 
Community Home Request Access Read Blogs Share Your Ideas Search Community View My Settings
Reply
Copper Contributor
Posts: 17
Registered: ‎08-18-2010

Firefox 8 Not Supported?

[ Edited ]

Finally upgrading from 6.2 to the 7.5/Web next week.

Testing now...

 

Noticed that the Firefox XPI included with the SlxDesktopIntegrationSetup.exe is not even compatible with the latest version of Firefox (v8, which has been out for over a month).

 

What the deal here?

 

Does Sage usually keep up with FF releases?Or do they fall behind a lot?

 

Has anyone tweaked the XPI to work with Firefox 8 with success?

Mozilla KB - Editing an add-on to change its compatibility

 

EDIT:

Just checking out the compatibility guide. Only FF 3 and IE 8 are supported?  That's not even the latest version of IE?!?

 

 

Gold Super Contributor
Posts: 3,087
Registered: ‎03-19-2009

Re: Firefox 8 Not Supported?

Correct.. in the FF area... FF must be less than 4.0.

 

Now if you do NOT want to use the desktop integration features (ex Outlook integration.. sendSLX, etc), then FF 8 seems to be just fine.. that is what I use - but I also use the WIndows?LAN (remote) client as well ;-)

--
RJ Ledger - rjledger@rjlSystems.net +1 603.369.3047 x101

".. Innovators in Mobility - Experts in Workflow Automation..."
http://www.rjlSystems.net - blog: www.rjlSystems.net/blog.html
Copper Contributor
Posts: 17
Registered: ‎08-18-2010

Re: Firefox 8 Not Supported?

What about the latest version of IE?

 

Is this stuff even on Sage's radar?  How can they have a 'WEB' client that doesn't even support current browsers?  Aren't they making the Web/Cloud thier defacto going forward?

Gold Super Contributor
Posts: 3,087
Registered: ‎03-19-2009

Re: Firefox 8 Not Supported?

IE9 in Sawgrass (vers 8.0 - not yet even beta announced)

--
RJ Ledger - rjledger@rjlSystems.net +1 603.369.3047 x101

".. Innovators in Mobility - Experts in Workflow Automation..."
http://www.rjlSystems.net - blog: www.rjlSystems.net/blog.html
Silver Contributor
Posts: 835
Registered: ‎03-24-2009

Re: Firefox 8 Not Supported?

I'm sorry, which hour's version of FF did you want SLX to keep up with? 5 versions in 5 months is a little too much IMHO.
RJ Samp
Copper Contributor
Posts: 17
Registered: ‎08-18-2010

Re: Firefox 8 Not Supported?

Look, I see your point, I don't agree with their new versioning methodology either, but almost all XPI's developed for FF 4 or greater still work with 8.x.  Never do I see an XPI that isn't supported anymore.  Even Adobe who is notorious for slow dev, even supports v8.

 

What's the argument for not supporting IE 9? 

How hard is to change a little code, repack the MSI, and release a new version of the Outlook Integration?  Why are they waiting till SLX Version 8?

Silver Contributor
Posts: 835
Registered: ‎03-24-2009

Re: Firefox 8 Not Supported?

[ Edited ]

IE 9 is a Microsoft thing....they haven't got on the HTML5\CSS3 bandwagon entirely....that is changing, quickly however.....Windows 8......(heck SQL Server 2012 is right around the corner....)

 

FF version 8 came out last month, I don't expect anyone to be up to speed on it....and having your developers up to speed on any version of FF.....what was your target 90 days ago, 180 days ago FF4? 5 (whatever happened to it?), 6? 7? ? When did FF announce v8 alpha, beta, release data?

 

this stuff is coming at the speed of light.....

 

Bottom Line: Sage SalesLogix has been dragging their feet on getting a fix to FF's new method for incorporating Add-Ins introduced in FF version 4.00.....should have been fixed by Sage month's ago, still hasn't been....and now supposedly is fixed in SLX v8\Sawgrass. Sounds like a marketing action to 'coax' Sage Customer's up to v8 and we're struggling to have them upgrade on 7.5.4 to fix all of the ills of 7.5.1, 7.5.2, and improve the SLX Mobil\ sData links\Secured Actions of  7.5.3 (and take advantage of the Web Client's cool javascript based NotesHistory form.

 

The silence from Sage  up here has been deafening......

RJ Samp
Moderator
Posts: 440
Registered: ‎05-07-2008

Re: Firefox 8 Not Supported?

Technically, the issue with supporting FF 4.x +, is that the Mozilla team has decided to no longer holds the "Binary" plugin interface stable.  At this point they have changed that interface in every version since FF4+.  We are currently working on a solution but as you can imagine it is a difficult game of cat and mouse.  

 

 

John Perona

Director, Infor CRM Development

Infor CRM

Infor CRM

Silver Contributor
Posts: 835
Registered: ‎03-24-2009

Re: Firefox 8 Not Supported?

Thanks John, now I've got a story to tell the customers!

RJ Samp
Highlighted
Gold Super Contributor
Posts: 3,087
Registered: ‎03-19-2009

Re: Firefox 8 Not Supported?

Have you guys taken a look to see what needs to be done to support Chrome?

 

Seems that Google has been doing a better job w/their browser than the FF folks have.

 

I run into more people who use chrome as their "main" or "Secondary" browser than I do people who have FF at all! They seem to like the simplicity and speed of it over FF (or IE). I know that I do 90% of my "browsing" w/chrome.. in fact, I do 100% of my SlxCommunity, SLx SUpport site and partner site stuff with it.

 

The only time I use IE is when I'm forced to (like the Sage KB site.. Unfortunately). I only use FF for some mobile web dev stuff because of FireBug.. and that's it.

--
RJ Ledger - rjledger@rjlSystems.net +1 603.369.3047 x101

".. Innovators in Mobility - Experts in Workflow Automation..."
http://www.rjlSystems.net - blog: www.rjlSystems.net/blog.html