Showing results for 
Search instead for 
Do you mean 
Community Home Request Access Read Blogs Share Your Ideas Search Community View My Settings
Reply
Copper Super Contributor
Posts: 172
Registered: ‎07-06-2010

Cannot use Application Architect after applying 7.5 SP2

I have been able to replicate this on 4 different machines.

 

I am attempting to install App Architect, SLX Server, Administrator, and SpeedSearch. After completing the baseline installation, I have verified that I can open Application Architect without any problems.

 

Once I apply SP2, I cannot open App Architect without getting the following error during the "Initializing Services" step as it launches:

 

Core Service Sage.SalesLogix.Security.FieldLevelSecurityService, Sage.SalesLogix.Security, is not available and is required to run this application.

 

AA finishes loading, but the deployment is totally hosed with a variety of web exceptions.

 

On another machine I fiddled around with the SalesLogix.xml file and changed the following line:

<Service TypeName="Sage.SalesLogix.Security.FieldLevelSecurityService, Sage.SalesLogix.Security"             RegisterAs="Sage.Platform.Security.IFieldLevelSecurityService, Sage.Platform"             AddOnDemand="false" />

 

I changed AddOnDemand to "true". It got me past the exception on load, but the deployment is still a mess.

 

Copper Super Contributor
Posts: 172
Registered: ‎07-06-2010

Re: Cannot use Application Architect after applying 7.5 SP2

In addition to the above problem I also cannot load any bundles from Architect without getting a number of errors complaining about corrupt streams. I've applied the SP2 web bundle, but this hasn't worked at all.

Copper Super Contributor
Posts: 172
Registered: ‎07-06-2010

Re: Cannot use Application Architect after applying 7.5 SP2

It turns out that this is (probably) a driver issue with Oracle 11g, the SLX OLEDB provider, and 7.5.2. When I reverted back to 10g R2 (10.2.0.1), App Architect loads correctly.

Gold Super Contributor
Posts: 3,087
Registered: ‎03-19-2009

Re: Cannot use Application Architect after applying 7.5 SP2

AFAIK - you need v7.5.4 for Oracle 11g

--
RJ Ledger - rjledger@rjlSystems.net +1 603.369.3047 x101

".. Innovators in Mobility - Experts in Workflow Automation..."
http://www.rjlSystems.net - blog: www.rjlSystems.net/blog.html
New Member
Posts: 3
Registered: ‎03-27-2012

Re: Cannot use Application Architect after applying 7.5 SP2

To open Application Architect (AA) without errors, you should update first your database to the corresponding version applying the bundle in Administrator.

In my case I had to charge a backup of the site from the install disc (SP4), then I can build and deploy the sites in AA without problems.

Check the task #44 in:
http://www.empath-e.com/documents/v754/ReleaseNotes/Applying_Service_Pack_4_for_Sage_SalesLogix_Vers...