Showing results for 
Search instead for 
Do you mean 
Community Home Request Access Read Blogs Share Your Ideas Search Community View My Settings
Reply
New Member
Posts: 6
Registered: ‎10-14-2011

8.1 build error: No CodeDom provider defined for the language

I'm upgrading a working 7.5.4 web/application test server to 8.1 Update 03, following the steps in the "Upgrading to Saleslogix version 8.1" document.

 

I've made it to step 56, where I'm supposed to be able to build and deploy the portals in Application Architect. But when I try to build, I get this error:

 

An application exception has occurred.
Additional information:
Build failed. (Sage.Platform.AdminModule)
There is no CodeDom provider defined for the language. (System)

 

I'm mainly trying to build the project from the VFS, which is the clean project from the 8.1 installation media, plus updates through 03. But the same error happens if I try to build a clean disk-based project.

 

A little poking around Google shows that "no CodeDom provider" could indicate that Application Architect can't find the compiler. I have no clue why this might be happening. Just to rule it out, I tried specifying the C# compiler in machine.config, but that didn't help. (I think that's supposed to be unnecessary anyway with the current Framework.)

 

The server has Visual Studio 2010 installed, and it's always worked fine alongside 7.5.4. I tried repairing it, but the build still doesn't work. Do I possibly need to rip this out, or replace with a newer version?

 

I have a separate 8.1 update 03 environment built from scratch, and it works just fine. I've looked at a few diffs of key directories on the two servers, but I'm not finding any clues.

 

I also tried a couple of different build search paths, as described here: http://community.saleslogix.com/t5/Administration/New-Install-v8-x-on-brand-new-server/m-p/149473/hi... But those didn't make any difference.

 

I do want to go through the actual upgrade steps to mimic what we will eventually do in production. I could skip this whole process and just build a clean server, but then I'd be missing the steps that upgrade our database to the 8.1 schema.

 

Any ideas?

Employee
Posts: 629
Registered: ‎04-24-2009

Re: 8.1 build error: No CodeDom provider defined for the language

Hi Scott,

 

I haven't seen that issue before. Is the .NET Framework 4.5 installed?

 

Thanks

 

Mike

Highlighted
New Member
Posts: 6
Registered: ‎10-14-2011

Re: 8.1 build error: No CodeDom provider defined for the language

Yes, I verified that it's installed, and also repaired it just in case anything had gotten corrupted.

 

I tried removing Visual Studio, but the problem persisted. Now I have removed the Saleslogix components and I'm reinstalling. I may need to reimage the server if I'm still stuck, since I know building from scratch works OK.